西数超哥博客
运维经验教程分享的博客

安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

由于本站服务器进行了调整,所有的运行环境都进行了重装,打算把zabbix安装起来,以便服务器啥情况都有通知可以收到。于是到官网下载当前最新版本zabbix 3.4来安装,还是和之前的依赖略有不同,譬如:
版本编译报错configure: error: Unable to use libevent (libevent check failed)
解决办法如下:

yum install libevent-devel  -y

问题解决。

 

说明:当前我用的编译参数如下

./configure --prefix=/usr/local/zabbix/ --enable-server  --with-mysql --with-net-snmp --with-libcurl --with-libxml2 --with-unixodbc

如服务器是新服务器,一般依赖不足。建议一起安装如下依赖,减少因为缺少依赖报错的可能性:

yum install unixODBC-devel mysql-devel net-snmp-devel libxml2-devel libcurl-devel libevent-devel

转载请注明:西数超哥博客www.ysidc.top» 安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

https://www.ysidc.top 西数超哥博客,数据库,西数超哥,虚拟主机,域名注册,域名,云服务器,云主机,云建站,ysidc.top

赞(0) 打赏
声明:本站发布的内容(图片、视频和文字)以原创、转载和分享网络内容为主,若涉及侵权请及时告知,将会在第一时间删除。本站原创内容未经允许不得转载:西数超哥学习乐园 » 安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏